Announcement

Collapse
No announcement yet.

Gearbox Speedo Sensor

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gearbox Speedo Sensor

    As title really, any chance someone has one?

  • #2
    We don't use sensors. Its a gear driven cable to the speedometer, with an electrical signal being out from the speedometer to the ECU.

    So, exactly which bit do you need?

    Comment


    • #3
      I also believe that there is a difference for the Evo III gear as well. My too sure on that though.

      Comment


      • #4
        Originally posted by EvoMayhem View Post
        We don't use sensors. Its a gear driven cable to the speedometer, with an electrical signal being out from the speedometer to the ECU.

        So, exactly which bit do you need?
        I'd say the plug shaped thing at the end of the speedo cable which attaches to the top of the gearbox at the back of the engine bay. Its an EVO 1 just in case there is a difference on the 3. The speedo isn't working at the moment and mine appears damaged/loose so thought changing it might sort it.
        Cheers

        Comment


        • #5
          Was your speedo reading in mph, or kph?

          If it reads mph, it could be the aftermarket converter that's buggered.

          Best bet if its the not the converter, is to go to the parts dept of Mitsi and order the bit you need. They should print out a blown up diagram of the assembly, and you can confirm what you need before ordering.

          It could even be the cable itself.

          Comment


          • #6
            Originally posted by EvoMayhem View Post
            Was your speedo reading in mph, or kph?

            If it reads mph, it could be the aftermarket converter that's buggered.

            Best bet if its the not the converter, is to go to the parts dept of Mitsi and order the bit you need. They should print out a blown up diagram of the assembly, and you can confirm what you need before ordering.

            It could even be the cable itself.
            Yeah its intermittent but reading mph when its working. I think I'll try the converter first then and go down the mitsi route if that fails. Any idea where I can get a converter from? Does this sit with the sender at the top if the gearbox?
            Thanks

            Comment


            • #7
              Originally posted by evofoz View Post
              Yeah its intermittent but reading mph when its working. I think I'll try the converter first then and go down the mitsi route if that fails. Any idea where I can get a converter from? Does this sit with the sender at the top if the gearbox?
              Thanks
              Buy a mechanical one off of eBay. They work fine.

              The cable screws into one end, and the converter then just screws onto the gearbox.

              Comment


              • #8
                I think I might have one I bought and never used.

                Ill check.

                Comment


                • #9
                  Originally posted by HOL View Post
                  I think I might have one I bought and never used.

                  Ill check.
                  Cheers, much appreciated.

                  Comment


                  • #10
                    Sorry, been out all day. Not had a chance to check where it is.

                    Comment

                    Working...
                    X