Announcement

Collapse
No announcement yet.

My EVO 2 screams 10k rpm @ low boost

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • My EVO 2 screams 10k rpm @ low boost

    i was wondering if anybody here running PPG dogbox and had issue with dog gears?

    mine got worn two times both 2nd gear and after few runs it does not want to stay in 2nd gear at all. throws out even if i try to hold shifter with hand.

    p.s. 2 liter, 10k rpm, 100octane fuel 1.8 bar boost, s475 turbo

    https://www.youtube.com/watch?v=fCrfAfdpGis

  • #2
    1st thing I'd look at is linkage and engine mounts - excessive movement can cause problems
    After that it's gearbox out and rebuild :(

    Mike

    Comment


    • #3
      I am sure that is one hell of a fun ride!!

      But concerning the issue with staying in second, I had seen something about bearing clearences or something needed to be a little bit larger. I do forget frankly. My GO-TO man is Tim Zimmer. Do you know who that is?

      Comment


      • #4
        Tim already replied to him on another forum. Possible issue with the forks, maybe.

        Comment


        • #5
          Originally posted by GeorgeGG View Post
          i was wondering if anybody here running PPG dogbox and had issue with dog gears?

          mine got worn two times both 2nd gear and after few runs it does not want to stay in 2nd gear at all. throws out even if i try to hold shifter with hand.

          p.s. 2 liter, 10k rpm, 100octane fuel 1.8 bar boost, s475 turbo

          https://www.youtube.com/watch?v=fCrfAfdpGis
          Got some photos of your Evo George? We would love to see more of it!

          Comment


          • #6
            Another ppg box with 2nd gear issues. Quite concerning. Have you talked to them at all? You aren't alone with 2nd gear pop out. Im looking at a ppg box but quite hesitant until i learn how this problem can be avoided

            Comment

            Working...
            X